# CVE-2022-42953: Missing authorization in n/a

> Attackers can access sensitive information via direct URL requests on ZKTeco devices, requiring firmware upgrades to mitigate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-54r9-6x6g-2vfv

## What is CVE-2022-42953?

CVE-2022-42953 is a high-severity missing authorization vulnerability in n/a, published on 25 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Certain ZKTeco products (ZEM500-510-560-760, ZEM600-800, ZEM720, ZMM) allow access to sensitive information via direct requests for the form/DataApp?style=1 and form/DataApp?style=0 URLs. The affected versions may be before 8.88 (ZEM500-510-560-760, ZEM600-800, ZEM720) and 15.00 (ZMM200-220-210). The fixed versions are firmware version 8.88 (ZEM500-510-560-760, ZEM600-800, ZEM720) and firmware version 15.00 (ZMM200-220-210).

Weakness: CWE-425 (Direct Request)

## Which versions are affected by CVE-2022-42953?

It affects 10 products.


Products: Zkteco Zem500 Firmware, Zkteco Zem510 Firmware, Zkteco Zem560 Firmware, Zkteco Zem600 Firmware, Zkteco Zem720 Firmware, Zkteco Zem760 Firmware, Zkteco Zem800 Firmware, Zkteco Zmm200 Firmware, Zkteco Zmm210 Firmware, Zkteco Zmm220 Firmware.

## How do I fix CVE-2022-42953?

No fix has been published for CVE-2022-42953 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-42953 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-42953 exists.

Public exploit code:

- ZKTeco ZEM/ZMM 8.88 - Missing Authentication (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42953 and fix it if it is affected.

What it is: CVE-2022-42953 is a high-severity missing authorization vulnerability in n/a, published on 25 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-42953 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42953/ (Markdown: https://insights.sbomify.com/CVE-2022-42953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42953
- OSV: https://osv.dev/vulnerability/CVE-2022-42953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42953/
Summaries are generated and may contain mistakes; the official description above is the record.
