# CVE-2022-42966: Exponential ReDoS in cleo leads to denial of service

> An attacker can cause a denial of service in the cleo Python library by supplying malicious input to the Table.set_rows method, triggering exponential regex backtracking.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2022
- **Updated:** 1 May 2025
- **Also known as:** GHSA-2p9h-ccw7-33gf, PYSEC-2022-43178, UBUNTU-CVE-2022-42966

## What is CVE-2022-42966?

CVE-2022-42966 is a medium-severity denial of service vulnerability in cleo, published on 9 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the cleo PyPI package, when an attacker is able to supply arbitrary input to the Table.set_rows method

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-42966?

3 open source packages ship an affected version, including cleo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cleo` | PyPI | All versions | 2.0.0 |
| `cleo` | PyPI | From 1.0.0a1 | 2.0.0 |
| `cleo` | PyPI | From 1.0.0a1 | 2.0.0 |

Products: Python-Poetry Cleo.

## How do I fix CVE-2022-42966?

Upgrade cleo to 2.0.0 or later.

## Is CVE-2022-42966 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-42966 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42966 and fix it if it is affected.

What it is: CVE-2022-42966 is a medium-severity denial of service vulnerability in cleo, published on 9 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-42966 exists.

Affected packages and fixed versions:
- cleo (PyPI): affected all versions; fixed in 2.0.0
- cleo (PyPI): affected from 1.0.0a1; fixed in 2.0.0
- cleo (PyPI): affected from 1.0.0a1; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42966/ (Markdown: https://insights.sbomify.com/CVE-2022-42966/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42966
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42966
- OSV: https://osv.dev/vulnerability/CVE-2022-42966

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42966/
Summaries are generated and may contain mistakes; the official description above is the record.
