# CVE-2022-42968: Gitea vulnerable to Argument Injection

> Attackers can execute arbitrary commands via unsanitized git refs in Gitea, requiring an upgrade to secure the service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2022
- **Updated:** 14 May 2025
- **Also known as:** BIT-gitea-2022-42968, CLEANSTART-2025-JO83815, GHSA-w8xw-7crf-h23x, GO-2022-1065

## What is CVE-2022-42968?

CVE-2022-42968 is a critical command injection vulnerability in Gitea Gitea, published on 16 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gitea before 1.17.3 does not sanitize and escape refs in the git backend. Arguments to git commands are mishandled.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-42968?

4 open source packages ship an affected version, including github.com/go-gitea/gitea, gitea and code.gitea.io/gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-gitea/gitea` | Go | All versions | 1.17.3 |
| `github.com/go-gitea/gitea` | Go | All versions | 1.17.3 |
| `gitea` | Bitnami | All versions | 1.17.3 |
| `code.gitea.io/gitea` | Go | All versions | 1.17.3 |

Products: Gitea Gitea.

## How do I fix CVE-2022-42968?

Upgrade github.com/go-gitea/gitea to 1.17.3 or later.

## Is CVE-2022-42968 being exploited?

There is no known exploitation of CVE-2022-42968 in the wild and no public exploit code.

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)
- [CVE-2021-45331](https://insights.sbomify.com/CVE-2021-45331/): Reuse of one time passwords allowed in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42968 and fix it if it is affected.

What it is: CVE-2022-42968 is a critical command injection vulnerability in Gitea Gitea, published on 16 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42968 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-gitea/gitea (Go): affected all versions; fixed in 1.17.3
- github.com/go-gitea/gitea (Go): affected all versions; fixed in 1.17.3
- gitea (Bitnami): affected all versions; fixed in 1.17.3
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.17.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42968/ (Markdown: https://insights.sbomify.com/CVE-2022-42968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42968
- OSV: https://osv.dev/vulnerability/CVE-2022-42968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42968/
Summaries are generated and may contain mistakes; the official description above is the record.
