# CVE-2022-42975: Phoenix before 1.6.14 mishandles check_origin wildcarding

> Attackers can bypass origin checks in Phoenix web applications if wildcarding is misconfigured, potentially enabling cross-site attacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2022
- **Updated:** 10 May 2025
- **Also known as:** GHSA-p8f7-22gq-m7j9

## What is CVE-2022-42975?

CVE-2022-42975 is a high-severity vulnerability in n/a, published on 17 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

socket/transport.ex in Phoenix before 1.6.14 mishandles check_origin wildcarding. NOTE: LiveView applications are unaffected by default because of the presence of a LiveView CSRF token.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-42975?

2 open source packages ship an affected version, including phoenix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phoenix` | Hex | All versions | 1.6.14 |
| `phoenix` | Hex | All versions | 1.6.14 |

Products: Phoenixframework Phoenix.

## How do I fix CVE-2022-42975?

Upgrade phoenix to 1.6.14 or later.

## Is CVE-2022-42975 being exploited?

There is no known exploitation of CVE-2022-42975 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-56811](https://insights.sbomify.com/CVE-2026-56811/): Phoenix transports do not limit channel joins per connection, enabling process-exhaustion denial of service (high 8.7)
- [CVE-2026-56812](https://insights.sbomify.com/CVE-2026-56812/): Phoenix: Presence keys colliding with `Object.prototype` members break existence checks (medium 6.3)
- [CVE-2017-1000163](https://insights.sbomify.com/CVE-2017-1000163/): Phoenix Arbitrary URL Redirect (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42975 and fix it if it is affected.

What it is: CVE-2022-42975 is a high-severity vulnerability in n/a, published on 17 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42975 in the wild and no public exploit code.

Affected packages and fixed versions:
- phoenix (Hex): affected all versions; fixed in 1.6.14
- phoenix (Hex): affected all versions; fixed in 1.6.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42975/ (Markdown: https://insights.sbomify.com/CVE-2022-42975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42975
- OSV: https://osv.dev/vulnerability/CVE-2022-42975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42975/
Summaries are generated and may contain mistakes; the official description above is the record.
