# CVE-2022-43138: Dolibarr vulnerable to privilege escalation


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Nov 2022
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-dolibarr-2022-43138, GHSA-gh7m-j673-wm97, UBUNTU-CVE-2022-43138

## What is CVE-2022-43138?

CVE-2022-43138 is a critical vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 17 Nov 2022. 

### Official description

Dolibarr Open Source ERP & CRM for Business before v14.0.1 allows attackers to escalate privileges via a crafted API.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-43138?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 14.0.1 |
| `dolibarr/dolibarr` | Packagist | All versions | 14.0.1 |
| `dolibarr` | Bitnami | All versions | 14.0.1 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2022-43138?

Upgrade dolibarr/dolibarr to 14.0.1 or later.

## Is CVE-2022-43138 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-43138 exists.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)
- [CVE-2013-2093](https://insights.sbomify.com/CVE-2013-2093/): Command injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43138 and fix it if it is affected.

What it is: CVE-2022-43138 is a critical vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 17 Nov 2022. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-43138 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 14.0.1
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 14.0.1
- dolibarr (Bitnami): affected all versions; fixed in 14.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43138/ (Markdown: https://insights.sbomify.com/CVE-2022-43138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43138
- OSV: https://osv.dev/vulnerability/CVE-2022-43138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43138/
Summaries are generated and may contain mistakes; the official description above is the record.
