# CVE-2022-4315: Missing authorization in GitLab

> GitLab DAST analyzer incorrectly sends custom request headers during authentication, potentially allowing attackers to bypass security controls.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2023
- **Updated:** 4 Mar 2025
- **Also known as:** BIT-gitlab-2022-4315, GHSA-342h-3rmj-qwv4

## What is CVE-2022-4315?

CVE-2022-4315 is a medium-severity missing authorization vulnerability in GitLab, published on 8 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab DAST analyzer affecting all versions starting from 2.0 before 3.0.55, which sends custom request headers with every request on the authentication page.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-4315?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 2.0.0 | 3.0.55 |

Products: Gitlab Dynamic Application Security Testing Analyzer.

## How do I fix CVE-2022-4315?

Upgrade gitlab to 3.0.55 or later.

## Is CVE-2022-4315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4315 exists.

## Other vulnerabilities in GitLab

- [CVE-2022-3767](https://insights.sbomify.com/CVE-2022-3767/): Server-side request forgery in DAST (high 7.7)
- [CVE-2023-0326](https://insights.sbomify.com/CVE-2023-0326/): Information disclosure in GitLab DAST API scanner (medium 5.0)
- [CVE-2022-4317](https://insights.sbomify.com/CVE-2022-4317/): Open redirect in DAST (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4315 and fix it if it is affected.

What it is: CVE-2022-4315 is a medium-severity missing authorization vulnerability in GitLab, published on 8 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4315 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 2.0.0; fixed in 3.0.55

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4315/ (Markdown: https://insights.sbomify.com/CVE-2022-4315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4315
- OSV: https://osv.dev/vulnerability/CVE-2022-4315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4315/
Summaries are generated and may contain mistakes; the official description above is the record.
