{"answers":{"affected":"1 open source package ship an affected version, including sass. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-43358 exists.","fix":"Upgrade sass to 3.6.5 or later.","what":"CVE-2022-43358 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-43358 and fix it if it is affected.\n\nWhat it is: CVE-2022-43358 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-43358 exists.\n\nAffected packages and fixed versions:\n- sass (Bitnami): affected from 3.6.5-8-g210218; fixed in 3.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43358/ (Markdown: https://insights.sbomify.com/CVE-2022-43358/index.md)","id":"CVE-2022-43358","markdown":"https://insights.sbomify.com/CVE-2022-43358/index.md","name":"CVE-2022-43358","record":{"aliases":["AZL-43987","AZL-44817","BIT-sass-2022-43358","DEBIAN-CVE-2022-43358","GHSA-57fv-hr9v-7rfx","UBUNTU-CVE-2022-43358"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Sass compiler library","requires_auth":"none","summary":"Attackers can cause a denial of service via stack overflow in the Sass compiler library, affecting applications using libsass.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libsass","vendor":"sass-lang"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Stack overflow vulnerability in ast_selectors.cpp: in function Sass::ComplexSelector::has_placeholder in libsass:3.6.5-8-g210218, which can be exploited by attackers to cause a denial of service (DoS).","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-43358","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2022-43359"},"packages":[{"ecosystem":"Bitnami","fixed":["3.6.5"],"introduced":["3.6.5-8-g210218"],"last_affected":[],"package":"sass","purl":"pkg:bitnami/sass","source":"BIT-sass-2022-43358"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2022-43357"},"products":["n/a"],"published":"2023-08-22","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2018-11499","kev_date_added":null,"published":"2018-05-26"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2022-26592","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":8.8,"headline":"Use after free in n/a","id":"CVE-2018-19827","kev_date_added":null,"published":"2018-12-03"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2018-11694","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2018-11695","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2018-11696","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":8.1,"headline":"Information disclosure in n/a","id":"CVE-2018-11693","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["n/a"]},"summary":"Attackers can cause a denial of service via stack overflow in the Sass compiler library, affecting applications using libsass.","url":"https://insights.sbomify.com/CVE-2022-43358/"}