# CVE-2022-43358: Denial of service in n/a

> Attackers can cause a denial of service via stack overflow in the Sass compiler library, affecting applications using libsass.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2023
- **Updated:** 3 Oct 2024
- **Also known as:** AZL-43987, AZL-44817, BIT-sass-2022-43358, DEBIAN-CVE-2022-43358, GHSA-57fv-hr9v-7rfx, UBUNTU-CVE-2022-43358

## What is CVE-2022-43358?

CVE-2022-43358 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Stack overflow vulnerability in ast_selectors.cpp: in function Sass::ComplexSelector::has_placeholder in libsass:3.6.5-8-g210218, which can be exploited by attackers to cause a denial of service (DoS).

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-43358?

1 open source package ship an affected version, including sass. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sass` | Bitnami | From 3.6.5-8-g210218 | 3.6.5 |

Products: Sass-Lang Libsass.

## How do I fix CVE-2022-43358?

Upgrade sass to 3.6.5 or later.

## Is CVE-2022-43358 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-43358 exists.

## Other vulnerabilities in n/a

- [CVE-2018-11499](https://insights.sbomify.com/CVE-2018-11499/): Use after free in n/a (critical 9.8)
- [CVE-2022-26592](https://insights.sbomify.com/CVE-2022-26592/): Memory corruption in n/a (high 8.8)
- [CVE-2018-19827](https://insights.sbomify.com/CVE-2018-19827/): Use after free in n/a (high 8.8)
- [CVE-2018-11694](https://insights.sbomify.com/CVE-2018-11694/): Null dereference in n/a (high 8.8)
- [CVE-2018-11695](https://insights.sbomify.com/CVE-2018-11695/): Null dereference in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43358 and fix it if it is affected.

What it is: CVE-2022-43358 is a high-severity denial of service vulnerability in n/a, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-43358 exists.

Affected packages and fixed versions:
- sass (Bitnami): affected from 3.6.5-8-g210218; fixed in 3.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43358/ (Markdown: https://insights.sbomify.com/CVE-2022-43358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43358
- OSV: https://osv.dev/vulnerability/CVE-2022-43358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43358/
Summaries are generated and may contain mistakes; the official description above is the record.
