# CVE-2022-43408: Jenkins Pipeline: Stage View Plugin allows CSRF protection bypass of any target URL in Jenkins

> Attackers can bypass CSRF protection in Jenkins by manipulating input step IDs in Pipeline configurations, potentially allowing unauthorized actions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** GHSA-g975-f26h-93g8

## What is CVE-2022-43408?

CVE-2022-43408 is a medium-severity vulnerability in Jenkins Pipeline: Stage View Plugin, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Pipeline: Stage View Plugin 2.26 and earlier does not correctly encode the ID of 'input' steps when using it to generate URLs to proceed or abort Pipeline builds, allowing attackers able to configure Pipelines to specify 'input' step IDs resulting in URLs that would bypass the CSRF protection of any target URL in Jenkins.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-43408?

4 open source packages ship an affected version, including org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view` | Maven | All versions | 2.24.2 |
| `org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view` | Maven | All versions | 2.24.2 |
| `org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view` | Maven | From 2.25 | 2.27 |
| `org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view` | Maven | From 2.25 | 2.27 |

Products: Jenkins Pipeline\.

## How do I fix CVE-2022-43408?

Upgrade org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view to a fixed version for your release line: 2.24.2 or 2.27.

## Is CVE-2022-43408 being exploited?

There is no known exploitation of CVE-2022-43408 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Pipeline: Stage View Plugin

- [CVE-2019-1003030](https://insights.sbomify.com/CVE-2019-1003030/): Jenkins Matrix Project Plugin Remote Code Execution (critical 9.9, exploited in the wild)
- [CVE-2022-43402](https://insights.sbomify.com/CVE-2022-43402/): Jenkins Pipeline: Groovy Plugin allows sandbox protection bypass and arbitrary code execution (critical 9.9)
- [CVE-2019-1003041](https://insights.sbomify.com/CVE-2019-1003041/): Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin (critical 9.8)
- [CVE-2022-43407](https://insights.sbomify.com/CVE-2022-43407/): CSRF protection for any URL can be bypassed in Jenkins Pipeline: Input Step Plugin (high 8.8)
- [CVE-2022-25173](https://insights.sbomify.com/CVE-2022-25173/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Pipeline: Groovy Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43408 and fix it if it is affected.

What it is: CVE-2022-43408 is a medium-severity vulnerability in Jenkins Pipeline: Stage View Plugin, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-43408 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view (Maven): affected all versions; fixed in 2.24.2
- org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view (Maven): affected all versions; fixed in 2.24.2
- org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view (Maven): affected from 2.25; fixed in 2.27
- org.jenkins-ci.plugins.pipeline-stage-view:pipeline-stage-view (Maven): affected from 2.25; fixed in 2.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43408/ (Markdown: https://insights.sbomify.com/CVE-2022-43408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43408
- OSV: https://osv.dev/vulnerability/CVE-2022-43408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43408/
Summaries are generated and may contain mistakes; the official description above is the record.
