{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:job-import-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-43413 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:job-import-plugin to 3.6 or later.","what":"CVE-2022-43413 is a medium-severity missing authorization vulnerability in Jenkins Job Import Plugin, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-43413 and fix it if it is affected.\n\nWhat it is: CVE-2022-43413 is a medium-severity missing authorization vulnerability in Jenkins Job Import Plugin, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-43413 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.6\n- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43413/ (Markdown: https://insights.sbomify.com/CVE-2022-43413/index.md)","id":"CVE-2022-43413","markdown":"https://insights.sbomify.com/CVE-2022-43413/index.md","name":"CVE-2022-43413","record":{"aliases":["GHSA-4g29-r7vj-2rpv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can enumerate stored credential IDs due to missing permission checks in the Jenkins Job Import Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"job_import","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Job Import Plugin allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins","id":"CVE-2022-43413","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins NUnit Plugin vulnerable to Protection Mechanism Failure","id":"CVE-2022-43414"},"packages":[{"ecosystem":"Maven","fixed":["3.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:job-import-plugin","purl":null,"source":"GHSA-4g29-r7vj-2rpv"},{"ecosystem":"Maven","fixed":["3.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:job-import-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/job-import-plugin","source":"GHSA-4g29-r7vj-2rpv"}],"prev":{"headline":"Non-constant time webhook token comparison in Jenkins Generic Webhook Trigger Plugin","id":"CVE-2022-43412"},"products":["Jenkins Job Import Plugin"],"published":"2022-10-19","related":[{"cvss_score":9.1,"headline":"XXE vulnerability in Jenkins Job Import Plugin","id":"CVE-2019-1003015","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":8.8,"headline":"Jenkins Job Import Plugin vulnerable to exposure of sensitive information","id":"CVE-2019-1003016","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":5.3,"headline":"Jenkins Job Import Plugin CSRF vulnerability","id":"CVE-2019-1003017","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":4.3,"headline":"Jenkins Job Import Plugin does not perform a permission check in an HTTP endpoint","id":"CVE-2026-48926","kev_date_added":null,"published":"2026-05-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-08","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can enumerate stored credential IDs due to missing permission checks in the Jenkins Job Import Plugin.","url":"https://insights.sbomify.com/CVE-2022-43413/"}