# CVE-2022-43413: Jenkins Job Import Plugin allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins

> Attackers with read permissions can enumerate stored credential IDs due to missing permission checks in the Jenkins Job Import Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** GHSA-4g29-r7vj-2rpv

## What is CVE-2022-43413?

CVE-2022-43413 is a medium-severity missing authorization vulnerability in Jenkins Job Import Plugin, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-43413?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:job-import-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:job-import-plugin` | Maven | All versions | 3.6 |
| `org.jenkins-ci.plugins:job-import-plugin` | Maven | All versions | 3.6 |

Products: Jenkins Job Import.

## How do I fix CVE-2022-43413?

Upgrade org.jenkins-ci.plugins:job-import-plugin to 3.6 or later.

## Is CVE-2022-43413 being exploited?

There is no known exploitation of CVE-2022-43413 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Job Import Plugin

- [CVE-2019-1003015](https://insights.sbomify.com/CVE-2019-1003015/): XXE vulnerability in Jenkins Job Import Plugin (critical 9.1)
- [CVE-2019-1003016](https://insights.sbomify.com/CVE-2019-1003016/): Jenkins Job Import Plugin vulnerable to exposure of sensitive information (high 8.8)
- [CVE-2019-1003017](https://insights.sbomify.com/CVE-2019-1003017/): Jenkins Job Import Plugin CSRF vulnerability (medium 5.3)
- [CVE-2026-48926](https://insights.sbomify.com/CVE-2026-48926/): Jenkins Job Import Plugin does not perform a permission check in an HTTP endpoint (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43413 and fix it if it is affected.

What it is: CVE-2022-43413 is a medium-severity missing authorization vulnerability in Jenkins Job Import Plugin, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43413 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.6
- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43413/ (Markdown: https://insights.sbomify.com/CVE-2022-43413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43413
- OSV: https://osv.dev/vulnerability/CVE-2022-43413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43413/
Summaries are generated and may contain mistakes; the official description above is the record.
