# CVE-2022-43414: Jenkins NUnit Plugin vulnerable to Protection Mechanism Failure

> Attackers controlling agent processes can read arbitrary test result files from the Jenkins controller via path traversal in the NUnit plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** GHSA-8cxw-wvhc-p4x4

## What is CVE-2022-43414?

CVE-2022-43414 is a medium-severity path traversal vulnerability in Jenkins NUnit Plugin, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins NUnit Plugin 0.27 and earlier implements an agent-to-controller message that parses files inside a user-specified directory as test results, allowing attackers able to control agent processes to obtain test results from files in an attacker-specified directory on the Jenkins controller.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2022-43414?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:nunit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:nunit` | Maven | All versions | 0.28 |
| `org.jenkins-ci.plugins:nunit` | Maven | All versions | 0.28 |

Products: Jenkins Nunit.

## How do I fix CVE-2022-43414?

Upgrade org.jenkins-ci.plugins:nunit to 0.28 or later.

## Is CVE-2022-43414 being exploited?

There is no known exploitation of CVE-2022-43414 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins NUnit Plugin

- [CVE-2020-2115](https://insights.sbomify.com/CVE-2020-2115/): XXE vulnerability in NUnit Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43414 and fix it if it is affected.

What it is: CVE-2022-43414 is a medium-severity path traversal vulnerability in Jenkins NUnit Plugin, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43414 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:nunit (Maven): affected all versions; fixed in 0.28
- org.jenkins-ci.plugins:nunit (Maven): affected all versions; fixed in 0.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43414/ (Markdown: https://insights.sbomify.com/CVE-2022-43414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43414
- OSV: https://osv.dev/vulnerability/CVE-2022-43414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43414/
Summaries are generated and may contain mistakes; the official description above is the record.
