# CVE-2022-43415: XXE vulnerability in Jenkins REPO Plugin

> An attacker can exploit XML external entity vulnerabilities in the Jenkins REPO Plugin to read sensitive files or cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 9 May 2025
- **Also known as:** GHSA-2w2m-ccf8-57cq

## What is CVE-2022-43415?

CVE-2022-43415 is a high-severity vulnerability in Jenkins REPO Plugin, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins REPO Plugin 1.15.0 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-43415?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:repo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:repo` | Maven | All versions | 1.16.0 |
| `org.jenkins-ci.plugins:repo` | Maven | All versions | 1.16.0 |

Products: Jenkins Repo.

## How do I fix CVE-2022-43415?

Upgrade org.jenkins-ci.plugins:repo to 1.16.0 or later.

## Is CVE-2022-43415 being exploited?

There is no known exploitation of CVE-2022-43415 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins REPO Plugin

- [CVE-2022-30949](https://insights.sbomify.com/CVE-2022-30949/): Path traversal in Jenkins REPO Plugin (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43415 and fix it if it is affected.

What it is: CVE-2022-43415 is a high-severity vulnerability in Jenkins REPO Plugin, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43415 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:repo (Maven): affected all versions; fixed in 1.16.0
- org.jenkins-ci.plugins:repo (Maven): affected all versions; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43415/ (Markdown: https://insights.sbomify.com/CVE-2022-43415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43415
- OSV: https://osv.dev/vulnerability/CVE-2022-43415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43415/
Summaries are generated and may contain mistakes; the official description above is the record.
