# CVE-2022-43416: Jenkins Katalon Plugin vulnerable to Protection Mechanism Failure

> Attackers with agent control and file creation permissions can execute arbitrary OS commands on the Jenkins controller via the Katalon Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** GHSA-q6f6-6c4p-xph4

## What is CVE-2022-43416?

CVE-2022-43416 is a high-severity command injection vulnerability in Jenkins Katalon Plugin, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Katalon Plugin 1.0.32 and earlier implements an agent/controller message that does not limit where it can be executed and allows invoking Katalon with configurable arguments, allowing attackers able to control agent processes to invoke Katalon on the Jenkins controller with attacker-controlled version, install location, and arguments, and attackers additionally able to create files on the Jenkins controller (e.g., attackers with Item/Configure permission could archive artifacts) to invoke arbitrary OS commands.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-43416?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:katalon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:katalon` | Maven | All versions | 1.0.33 |
| `org.jenkins-ci.plugins:katalon` | Maven | All versions | 1.0.33 |

Products: Jenkins Katalon.

## How do I fix CVE-2022-43416?

Upgrade org.jenkins-ci.plugins:katalon to 1.0.33 or later.

## Is CVE-2022-43416 being exploited?

There is no known exploitation of CVE-2022-43416 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Katalon Plugin

- [CVE-2022-43419](https://insights.sbomify.com/CVE-2022-43419/): API keys stored in plain text by Jenkins Katalon Plugin (medium 6.5)
- [CVE-2022-43417](https://insights.sbomify.com/CVE-2022-43417/): Missing permission checks in Jenkins Katalon Plugin allow capturing credentials (medium 4.3)
- [CVE-2022-43418](https://insights.sbomify.com/CVE-2022-43418/): CSRF vulnerability in Jenkins Katalon Plugin allows capturing credentials (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43416 and fix it if it is affected.

What it is: CVE-2022-43416 is a high-severity command injection vulnerability in Jenkins Katalon Plugin, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43416 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:katalon (Maven): affected all versions; fixed in 1.0.33
- org.jenkins-ci.plugins:katalon (Maven): affected all versions; fixed in 1.0.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43416/ (Markdown: https://insights.sbomify.com/CVE-2022-43416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43416
- OSV: https://osv.dev/vulnerability/CVE-2022-43416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43416/
Summaries are generated and may contain mistakes; the official description above is the record.
