CVE-2022-4343 Exposure of Sensitive Information to an Unauthorized Actor in GitLab
A project member can leak credentials stored in the site profile, exposing sensitive information to unauthorized actors.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-4343?
CVE-2022-4343 is a medium-severity vulnerability in Gitlab Gitlab, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1 in which a project member can leak credentials stored in site profile.
Weakness: CWE-200
Which versions are affected by CVE-2022-4343?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.12.0 | 16.1.5, 16.2.5, 16.3.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-4343?
Upgrade gitlab to a fixed version for your release line: 16.1.5, 16.2.5 or 16.3.1.
Is CVE-2022-4343 being exploited?
There is no known exploitation of CVE-2022-4343 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-4343, GHSA-xcv9-mgjj-4fmc.