CVE-2022-43500 Cross-site scripting in WordPress
Remote unauthenticated attackers can inject arbitrary scripts into WordPress, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-43500?
CVE-2022-43500 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
Weakness: CWE-79
Which versions are affected by CVE-2022-43500?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | All versions | 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3 |
wordpress-multisite Bitnami | All versions | 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3 |
Products include Wordpress Wordpress.
How do I fix CVE-2022-43500?
Upgrade wordpress to a fixed version for your release line: 3.7.40, 3.8.40, 3.9.39 or 4.0.37.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-43500 being exploited?
There is no known exploitation of CVE-2022-43500 in the wild and no public exploit code.
Other vulnerabilities in Wordpress Wordpress
Sources
Also known as BIT-wordpress-2022-43500, BIT-wordpress-multisite-2022-43500, DEBIAN-CVE-2022-43500, GHSA-hm6q-fjph-v26v, UBUNTU-CVE-2022-43500.