{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-43500 in the wild and no public exploit code.","fix":"Upgrade wordpress to a fixed version for your release line: 3.7.40, 3.8.40, 3.9.39 or 4.0.37.","what":"CVE-2022-43500 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-43500 and fix it if it is affected.\n\nWhat it is: CVE-2022-43500 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-43500 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3\n- wordpress-multisite (Bitnami): affected all versions; fixed in 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43500/ (Markdown: https://insights.sbomify.com/CVE-2022-43500/index.md)","id":"CVE-2022-43500","markdown":"https://insights.sbomify.com/CVE-2022-43500/index.md","name":"CVE-2022-43500","record":{"aliases":["BIT-wordpress-2022-43500","BIT-wordpress-multisite-2022-43500","DEBIAN-CVE-2022-43500","GHSA-hm6q-fjph-v26v","UBUNTU-CVE-2022-43500"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress CMS","requires_auth":"none","summary":"Remote unauthenticated attackers can inject arbitrary scripts into WordPress, potentially leading to code execution or account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in WordPress","id":"CVE-2022-43500","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Weak cryptography in Kasago IPv4","id":"CVE-2022-43501"},"packages":[{"ecosystem":"Bitnami","fixed":["3.7.40","3.8.40","3.9.39","4.0.37","4.1.37","4.2.34","4.3.30","4.4.29","4.5.28","4.6.25","4.7.25","4.8.21","4.9.22","5.0.18","5.1.15","5.2.17","5.3.14","5.4.12","5.5.11","5.6.10","5.7.8","5.8.6","5.9.5","6.0.3"],"introduced":["0","3.8.0","3.9.0","4.0.0","4.1.0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2022-43500"},{"ecosystem":"Bitnami","fixed":["3.7.40","3.8.40","3.9.39","4.0.37","4.1.37","4.2.34","4.3.30","4.4.29","4.5.28","4.6.25","4.7.25","4.8.21","4.9.22","5.0.18","5.1.15","5.2.17","5.3.14","5.4.12","5.5.11","5.6.10","5.7.8","5.8.6","5.9.5","6.0.3"],"introduced":["0","3.8.0","3.9.0","4.0.0","4.1.0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2022-43500"}],"prev":{"headline":"Cross-site scripting in SHIRASAGI","id":"CVE-2022-43499"},"products":["WordPress"],"published":"2022-12-05","related":[{"cvss_score":9.8,"headline":"WordPress Core Interpretation Conflict","id":"CVE-2026-63030","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":8.1,"headline":"WordPress Core Remote File Inclusion","id":"CVE-2026-87902","kev_date_added":"2026-09-25","published":"2026-09-22"},{"cvss_score":5.9,"headline":"WordPress Core SQL Injection","id":"CVE-2026-60137","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2399","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2012-2400","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3122","kev_date_added":null,"published":"2011-08-10"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3125","kev_date_added":null,"published":"2011-08-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-24","vendors":["WordPress.org"]},"summary":"Remote unauthenticated attackers can inject arbitrary scripts into WordPress, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2022-43500/"}