# CVE-2022-43504: Information disclosure in WordPress

> Remote attackers can obtain user email addresses via the Post by Email feature, requiring this feature to be enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2022
- **Updated:** 24 Apr 2025
- **Also known as:** BIT-wordpress-2022-43504, BIT-wordpress-multisite-2022-43504, DEBIAN-CVE-2022-43504, GHSA-h8vf-v4qw-mvq4, UBUNTU-CVE-2022-43504

## What is CVE-2022-43504?

CVE-2022-43504 is a medium-severity vulnerability in Wordpress Wordpress, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper authentication vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to obtain the email address of the user who posted a blog using the WordPress Post by Email Feature. The developer also provides new patched releases for all versions since 3.7.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-43504?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3 |
| `wordpress-multisite` | Bitnami | All versions | 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3 |

Products: Wordpress Wordpress.

## How do I fix CVE-2022-43504?

Upgrade wordpress to a fixed version for your release line: 3.7.40, 3.8.40, 3.9.39 or 4.0.37.

## Is CVE-2022-43504 being exploited?

There is no known exploitation of CVE-2022-43504 in the wild and no public exploit code.

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43504 and fix it if it is affected.

What it is: CVE-2022-43504 is a medium-severity vulnerability in Wordpress Wordpress, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43504 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3
- wordpress-multisite (Bitnami): affected all versions; fixed in 3.7.40, 3.8.40, 3.9.39, 4.0.37, 4.1.37, 4.2.34, 4.3.30, 4.4.29, 4.5.28, 4.6.25, 4.7.25, 4.8.21, 4.9.22, 5.0.18, 5.1.15, 5.2.17, 5.3.14, 5.4.12, 5.5.11, 5.6.10, 5.7.8, 5.8.6, 5.9.5, 6.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43504/ (Markdown: https://insights.sbomify.com/CVE-2022-43504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43504
- OSV: https://osv.dev/vulnerability/CVE-2022-43504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43504/
Summaries are generated and may contain mistakes; the official description above is the record.
