{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-43507 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-43507 is a high-severity memory corruption vulnerability in Intel(R) QAT Engine for OpenSSL, published on 10 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-43507 and fix it if it is affected.\n\nWhat it is: CVE-2022-43507 is a high-severity memory corruption vulnerability in Intel(R) QAT Engine for OpenSSL, published on 10 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-43507 in the wild and no public exploit code.\n\nAffected product: Intel(R) QAT Engine for OpenSSL. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43507/ (Markdown: https://insights.sbomify.com/CVE-2022-43507/index.md)","id":"CVE-2022-43507","markdown":"https://insights.sbomify.com/CVE-2022-43507/index.md","name":"CVE-2022-43507","record":{"aliases":["GHSA-qq3q-8ccj-3w3c","SUSE-SU-2023:3290-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Intel QAT Engine","requires_auth":"none","summary":"A privileged user can escalate privileges via network access due to improper buffer restrictions in the Intel QAT Engine for OpenSSL.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"intel","cpe":[{"product":"quickassist_technology_engine","vendor":"intel"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"},{"id":"CWE-92","name":"DEPRECATED: Improper Sanitization of Custom Special Characters"}],"description":"Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP4","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in Intel(R) QAT Engine for OpenSSL","id":"CVE-2022-43507","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Use after free in CX-Programmer","id":"CVE-2022-43508"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP4","fixed":["0.6.10-150400.3.3.1"],"introduced":["0"],"last_affected":[],"package":"qatengine","purl":"pkg:rpm/suse/qatengine\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP4","source":"SUSE-SU-2023:3290-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["0.6.10-150400.3.3.1"],"introduced":["0"],"last_affected":[],"package":"qatengine","purl":"pkg:rpm/opensuse/qatengine\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2023:3290-1"}],"prev":{"headline":"Delta Electronics DIAEnergie SQL Injection","id":"CVE-2022-43506"},"products":["Intel(R) QAT Engine for OpenSSL"],"published":"2023-05-10","related":[{"cvss_score":7.5,"headline":"Information disclosure in Intel Quick Assist Technology","id":"CVE-2017-5681","kev_date_added":null,"published":"2017-03-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-27","vendors":["n/a"]},"summary":"A privileged user can escalate privileges via network access due to improper buffer restrictions in the Intel QAT Engine for OpenSSL.","url":"https://insights.sbomify.com/CVE-2022-43507/"}