# CVE-2022-43556: Concrete CMS vulnerable to cross-site scripting in the text input field

> Attackers can inject malicious scripts into the Concrete CMS dashboard via unsanitized text input, potentially compromising user sessions or data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Dec 2022
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-xj33-8r43-r227

## What is CVE-2022-43556?

CVE-2022-43556 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to XSS in the text input field since the result dashboard page output is not sanitized. The Concrete CMS security team has ranked this 4.2 with CVSS v3.1 vector AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N Thanks @_akbar_jafarli_ for reporting. Remediate by updating to Concrete CMS 8.5.10 and Concrete CMS 9.1.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-43556?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 8.5.10 |
| `concrete5/concrete5` | Packagist | All versions | 8.5.10 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.1.3 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.1.3 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2022-43556?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.

## Is CVE-2022-43556 being exploited?

There is no known exploitation of CVE-2022-43556 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43556 and fix it if it is affected.

What it is: CVE-2022-43556 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-43556 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.10
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.10
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.1.3
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43556/ (Markdown: https://insights.sbomify.com/CVE-2022-43556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43556
- OSV: https://osv.dev/vulnerability/CVE-2022-43556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43556/
Summaries are generated and may contain mistakes; the official description above is the record.
