# CVE-2022-4361: Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC

> Attackers can execute malicious scripts in Keycloak SAML or OIDC providers via crafted URLs, potentially compromising user accounts.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2023
- **Updated:** 12 Nov 2024
- **Also known as:** GHSA-3p62-6fjh-3p5h

## What is CVE-2022-4361?

CVE-2022-4361 is a critical cross-site scripting vulnerability in Redhat Keycloak, published on 7 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Keycloak, an open-source identity and access management solution, has a cross-site scripting (XSS) vulnerability in the SAML or OIDC providers. The vulnerability can allow an attacker to execute malicious scripts by setting the AssertionConsumerServiceURL value or the redirect_uri.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-81 (Improper Neutralization of Script in an Error Message Web Page)

## Which versions are affected by CVE-2022-4361?

2 open source packages ship an affected version, including org.keycloak:keycloak-services. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.1.2 |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.1.2 |

Products: Redhat Keycloak, Redhat Openshift Container Platform, Redhat Openshift Container Platform for Ibm Linuxone, Redhat Openshift Container Platform for Power, Redhat Single Sign-On.

## How do I fix CVE-2022-4361?

Upgrade org.keycloak:keycloak-services to 21.1.2 or later.

## Is CVE-2022-4361 being exploited?

There is no known exploitation of CVE-2022-4361 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/keycloak__keycloak_CVE-2022-4361_21-1-1 (github_poc): https://github.com/shoucheng3/keycloak__keycloak_CVE-2022-4361_21-1-1
- PoC for https://nvd.nist.gov/vuln/detail/CVE-2022-4361 (github_poc): https://github.com/faccimatteo/CVE-2022-4361

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)
- [CVE-2022-3782](https://insights.sbomify.com/CVE-2022-3782/): Keycloak vulnerable to path traversal via double URL encoding (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4361 and fix it if it is affected.

What it is: CVE-2022-4361 is a critical cross-site scripting vulnerability in Redhat Keycloak, published on 7 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4361 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.1.2
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4361/ (Markdown: https://insights.sbomify.com/CVE-2022-4361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4361
- OSV: https://osv.dev/vulnerability/CVE-2022-4361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4361/
Summaries are generated and may contain mistakes; the official description above is the record.
