CVE-2022-4364 Teledyne FLIR AX8 Web Service palette.php command injection

Medium 6.9 Published Updated

Remote attackers can execute arbitrary commands via the palette.php web service handler in Teledyne FLIR AX8 devices.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-4364?

CVE-2022-4364 is a medium-severity command injection vulnerability in Teledyne FLIR AX8, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability has been found in Teledyne FLIR AX8 up to 1.46.16. Affected by this issue is some unknown functionality of the file palette.php of the component Web Service Handler. The manipulation of the argument palette leads to command injection. The attack is possible to be carried out remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.49.16 can resolve this issue. Upgrading the affected component is advised. The vendor points out: "FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities."

Weakness: CWE-78, CWE-77, CWE-74

Which versions are affected by CVE-2022-4364?

It affects 1 product.

Products include Flir Flir Ax8 Firmware.

How do I fix CVE-2022-4364?

No fix has been published for CVE-2022-4364 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2022-4364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4364 exists.

Sources

Also known as GHSA-vv59-hfvc-2j7h.

Is CVE-2022-4364 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free