CVE-2022-4365 Information disclosure in GitLab
A malicious Maintainer can leak the Sentry token by modifying the configured URL in the Sentry error tracking settings page.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-4365?
CVE-2022-4365 is a medium-severity vulnerability in Gitlab Gitlab, published on 12 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.8 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. A malicious Maintainer can leak the sentry token by changing the configured URL in the Sentry error tracking settings page.
Weakness: CWE-732
Which versions are affected by CVE-2022-4365?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.8.0 | 15.5.7, 15.6.4, 15.7.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-4365?
Upgrade gitlab to a fixed version for your release line: 15.5.7, 15.6.4 or 15.7.2.
Is CVE-2022-4365 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4365 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-4365, GHSA-cqj2-v4jv-jmhc, UBUNTU-CVE-2022-4365.