CVE-2022-43686 Concrete CMS vulnerable to Uncontrolled Resource Consumption leading to DoS

Medium 6.5 Published Updated

Attackers can fill the authTypeConcreteCookieMap table in Concrete CMS, causing high load and denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-43686?

CVE-2022-43686 is a medium-severity denial of service vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2, the authTypeConcreteCookieMap table can be filled up causing a denial of service (high load).

Weakness: CWE-770

Which versions are affected by CVE-2022-43686?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.10
concrete5/concrete5 PackagistAll versions8.5.10
concrete5/concrete5 PackagistFrom 9.0.09.1.3
concrete5/concrete5 PackagistFrom 9.0.09.1.3

Products include Concretecms Concrete Cms.

How do I fix CVE-2022-43686?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-43686 being exploited?

There is no known exploitation of CVE-2022-43686 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-3cxx-3f53-m92c.

Is CVE-2022-43686 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free