CVE-2022-43688 Concrete CMS vulnerable to Cross-site Scripting

Medium 4.8 Published Updated

Attackers can inject malicious scripts via unsanitized Microsoft application tile colors in Concrete CMS, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-43688?

CVE-2022-43688 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Stored Cross-Site Scripting (XSS) in icons since the Microsoft application tile color is not sanitized. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Weakness: CWE-79

Which versions are affected by CVE-2022-43688?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.10
concrete5/concrete5 PackagistAll versions8.5.10
concrete5/concrete5 PackagistFrom 9.0.09.1.3
concrete5/concrete5 PackagistFrom 9.0.09.1.3

Products include Concretecms Concrete Cms.

How do I fix CVE-2022-43688?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-43688 being exploited?

There is no known exploitation of CVE-2022-43688 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-9jc5-9wh5-mc36.

Is CVE-2022-43688 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free