CVE-2022-43690 Concrete CMS vulnerable to Improper Authentication

Medium 6.3 Published Updated

Attackers can bypass authentication in Concrete CMS if legacy salt functionality is enabled due to improper strict comparison checks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-43690?

CVE-2022-43690 is a medium-severity authentication bypass vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 did not use strict comparison for the legacy_salt so that limited authentication bypass could occur if using this functionality. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Weakness: CWE-287

Which versions are affected by CVE-2022-43690?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.10
concrete5/concrete5 PackagistAll versions8.5.10
concrete5/concrete5 PackagistFrom 9.0.09.1.3
concrete5/concrete5 PackagistFrom 9.0.09.1.3

Products include Concretecms Concrete Cms.

How do I fix CVE-2022-43690?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-43690 being exploited?

There is no known exploitation of CVE-2022-43690 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-q56r-mw39-944g.

Is CVE-2022-43690 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free