# CVE-2022-43690: Concrete CMS vulnerable to Improper Authentication

> Attackers can bypass authentication in Concrete CMS if legacy salt functionality is enabled due to improper strict comparison checks.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Nov 2022
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-q56r-mw39-944g

## What is CVE-2022-43690?

CVE-2022-43690 is a medium-severity authentication bypass vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 did not use strict comparison for the legacy_salt so that limited authentication bypass could occur if using this functionality. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-43690?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 8.5.10 |
| `concrete5/concrete5` | Packagist | All versions | 8.5.10 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.1.3 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.1.3 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2022-43690?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.

## Is CVE-2022-43690 being exploited?

There is no known exploitation of CVE-2022-43690 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43690 and fix it if it is affected.

What it is: CVE-2022-43690 is a medium-severity authentication bypass vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-43690 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.10
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.10
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.1.3
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43690/ (Markdown: https://insights.sbomify.com/CVE-2022-43690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43690
- OSV: https://osv.dev/vulnerability/CVE-2022-43690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43690/
Summaries are generated and may contain mistakes; the official description above is the record.
