CVE-2022-43691 Concrete CMS vulnerable to Cleartext Transmission of Sensitive Information
Attackers can read sensitive server secrets and environment variables if Concrete CMS Debug Mode is enabled in production.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-43691?
CVE-2022-43691 is a medium-severity vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 inadvertently disclose server-side sensitive information (secrets in environment variables and server information) when Debug Mode is left on in production.
Weakness: CWE-319
Which versions are affected by CVE-2022-43691?
4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 8.5.10 |
concrete5/concrete5 Packagist | All versions | 8.5.10 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.1.3 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.1.3 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2022-43691?
Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.
Is CVE-2022-43691 being exploited?
There is no known exploitation of CVE-2022-43691 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-q3hq-hm5h-qrx3.