{"answers":{"affected":"4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-43692 in the wild and no public exploit code.","fix":"Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.","what":"CVE-2022-43692 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-43692 and fix it if it is affected.\n\nWhat it is: CVE-2022-43692 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-43692 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.10\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.10\n- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.1.3\n- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43692/ (Markdown: https://insights.sbomify.com/CVE-2022-43692/index.md)","id":"CVE-2022-43692","markdown":"https://insights.sbomify.com/CVE-2022-43692/index.md","name":"CVE-2022-43692","record":{"aliases":["GHSA-rg6w-c352-p8pg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Concrete CMS","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in an administrator's browser via a crafted URL, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"concrete_cms","vendor":"concretecms"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Reflected XSS - user can cause an administrator to trigger reflected XSS with a url if the targeted administrator is using an old browser that lacks XSS protection. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Concrete CMS vulnerable to Reflected Cross-site Scripting","id":"CVE-2022-43692","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"concretecms:concrete_cms","products":["concretecms:concrete_cms"],"type":"xss","year":"2022"},"n_packages":4,"n_references":5,"next":{"headline":"Concrete CMS vulnerable to Cross-site Request Forgery","id":"CVE-2022-43693"},"packages":[{"ecosystem":"Packagist","fixed":["8.5.10"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-rg6w-c352-p8pg"},{"ecosystem":"Packagist","fixed":["8.5.10"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-rg6w-c352-p8pg"},{"ecosystem":"Packagist","fixed":["9.1.3"],"introduced":["9.0.0"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-rg6w-c352-p8pg"},{"ecosystem":"Packagist","fixed":["9.1.3"],"introduced":["9.0.0"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-rg6w-c352-p8pg"}],"prev":{"headline":"Concrete CMS vulnerable to Cleartext Transmission of Sensitive Information","id":"CVE-2022-43691"},"products":["n/a"],"published":"2022-11-14","related":[{"cvss_score":9.8,"headline":"Concrete CMS allows unauthorized access because directories can be created with insecure permissions","id":"CVE-2023-48648","kev_date_added":null,"published":"2023-11-17"},{"cvss_score":9.8,"headline":"Code injection in concrete CMS","id":"CVE-2022-21829","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.8,"headline":"Server-Side Request Forgery vulnerability in concrete5","id":"CVE-2021-22958","kev_date_added":null,"published":"2021-10-07"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2021-40098","kev_date_added":null,"published":"2021-09-27"},{"cvss_score":9.4,"headline":"Concrete CMS Vulnerable to Relative Path Traversal","id":"CVE-2026-8134","kev_date_added":null,"published":"2026-05-21"},{"cvss_score":9.1,"headline":"Path traversal in Concrete CMS","id":"CVE-2022-30117","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.1,"headline":"Deserialization in n/a","id":"CVE-2021-40102","kev_date_added":null,"published":"2021-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts in an administrator's browser via a crafted URL, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2022-43692/"}