CVE-2022-43695 Concrete CMS Cross-site Scripting vulnerability
Attackers can inject malicious scripts via unsanitized entity names in Concrete CMS, potentially executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-43695?
CVE-2022-43695 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 14 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Stored Cross-Site Scripting (XSS) in dashboard/system/express/entities/associations because Concrete CMS allows association with an entity name that doesn’t exist or, if it does exist, contains XSS since it was not properly sanitized. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.
Weakness: CWE-79
Which versions are affected by CVE-2022-43695?
4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 8.5.10 |
concrete5/concrete5 Packagist | All versions | 8.5.10 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.1.3 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.1.3 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2022-43695?
Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.10 or 9.1.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-43695 being exploited?
There is no known exploitation of CVE-2022-43695 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-8699-h45g-7hm8.