CVE-2022-43718 Apache Superset: Cross-Site Scripting vulnerability on upload forms
Authenticated users with database update permissions can execute arbitrary scripts via upload forms in Apache Superset.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-43718?
CVE-2022-43718 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
Weakness: CWE-79
Which versions are affected by CVE-2022-43718?
6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | None |
apache-superset PyPI | All versions | None |
apache-superset PyPI | All versions | 1.5.3, 2.0.1 |
apache-superset PyPI | All versions to 1.5.2 | None |
apache-superset PyPI | All versions to 1.5.2 | None |
superset Bitnami | All versions | 1.5.3, 2.0.1 |
Products include Apache Superset.
How do I fix CVE-2022-43718?
Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-43718 being exploited?
There is no known exploitation of CVE-2022-43718 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2022-43718, GHSA-79x5-cv79-49rj, PYSEC-2026-777.