{"answers":{"affected":"6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-43718 in the wild and no public exploit code.","fix":"Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.","what":"CVE-2022-43718 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-43718 and fix it if it is affected.\n\nWhat it is: CVE-2022-43718 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-43718 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions; no fix listed\n- apache-superset (PyPI): affected all versions; no fix listed\n- apache-superset (PyPI): affected all versions; fixed in 1.5.3, 2.0.1\n- apache-superset (PyPI): affected all versions up to 1.5.2; no fix listed\n- apache-superset (PyPI): affected all versions up to 1.5.2; no fix listed\n- superset (Bitnami): affected all versions; fixed in 1.5.3, 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43718/ (Markdown: https://insights.sbomify.com/CVE-2022-43718/index.md)","id":"CVE-2022-43718","markdown":"https://insights.sbomify.com/CVE-2022-43718/index.md","name":"CVE-2022-43718","record":{"aliases":["BIT-superset-2022-43718","GHSA-79x5-cv79-49rj","PYSEC-2026-777"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"Authenticated users with database update permissions can execute arbitrary scripts via upload forms in Apache Superset.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: Cross-Site Scripting vulnerability on upload forms","id":"CVE-2022-43718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"xss","year":"2022"},"n_packages":6,"n_references":1,"next":{"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719"},"packages":[{"ecosystem":"Bitnami","fixed":["1.5.3","2.0.1"],"introduced":["0","2.0.0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2022-43718"},{"ecosystem":"PyPI","fixed":[],"introduced":[],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-79x5-cv79-49rj"},{"ecosystem":"PyPI","fixed":[],"introduced":[],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-79x5-cv79-49rj"},{"ecosystem":"PyPI","fixed":["1.5.3","2.0.1"],"introduced":["0","2.0.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-777"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.5.2"],"package":"apache-superset","purl":null,"source":"GHSA-79x5-cv79-49rj"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.5.2"],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-79x5-cv79-49rj"}],"prev":{"headline":"Apache Superset: Cross-Site Scripting on dashboards","id":"CVE-2022-43717"},"products":["Apache Superset"],"published":"2023-01-16","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-07","vendors":["Apache Software Foundation"]},"summary":"Authenticated users with database update permissions can execute arbitrary scripts via upload forms in Apache Superset.","url":"https://insights.sbomify.com/CVE-2022-43718/"}