CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API

High 8.8 Published Updated

Attackers can force authenticated users to approve access requests via CSRF in Apache Superset, requiring an upgrade to secure the application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-43719?

CVE-2022-43719 is a high-severity vulnerability in Apache Superset, published on 16 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Two legacy REST API endpoints for approval and request access are vulnerable to cross site request forgery. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Weakness: CWE-352

Which versions are affected by CVE-2022-43719?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versionsNone
apache-superset PyPIAll versionsNone
apache-superset PyPIAll versions1.5.3, 2.0.1
apache-superset PyPIAll versions to 1.5.2None
apache-superset PyPIAll versions to 1.5.2None
superset BitnamiAll versions1.5.3, 2.0.1

Products include Apache Superset.

How do I fix CVE-2022-43719?

Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.

Is CVE-2022-43719 being exploited?

There is no known exploitation of CVE-2022-43719 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2022-43719, GHSA-7222-r37x-8q3m, PYSEC-2026-775.

Is CVE-2022-43719 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free