CVE-2022-43720 Apache Superset: Improper rendering of user input
An authenticated attacker can inject malicious HTML into CSS templates, leading to cross-site scripting when other users delete the template.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-43720?
CVE-2022-43720 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An authenticated attacker with write CSS template permissions can create a record with specific HTML tags that will not get properly escaped by the toast message displayed when a user deletes that specific CSS template record. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
Weakness: CWE-74
Which versions are affected by CVE-2022-43720?
6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | None |
apache-superset PyPI | All versions | None |
apache-superset PyPI | All versions | 1.5.3, 2.0.1 |
apache-superset PyPI | All versions to 1.5.2 | None |
apache-superset PyPI | All versions to 1.5.2 | None |
superset Bitnami | All versions | 1.5.3, 2.0.1 |
Products include Apache Superset.
How do I fix CVE-2022-43720?
Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-43720 being exploited?
There is no known exploitation of CVE-2022-43720 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2022-43720, GHSA-fpmr-qmgh-42x2, PYSEC-2026-782.