CVE-2022-43721 Apache Superset: Open Redirect Vulnerability

Medium 5.4 Published Updated

An authenticated attacker can redirect users to untrusted sites by modifying dataset links in Apache Superset.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-43721?

CVE-2022-43721 is a medium-severity vulnerability in Apache Superset, published on 16 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An authenticated attacker with update datasets permission could change a dataset link to an untrusted site, users could be redirected to this site when clicking on that specific dataset. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Weakness: CWE-601

Which versions are affected by CVE-2022-43721?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versionsNone
apache-superset PyPIAll versionsNone
apache-superset PyPIAll versions1.5.3, 2.0.1
apache-superset PyPIAll versions to 1.5.2None
apache-superset PyPIAll versions to 1.5.2None
superset BitnamiAll versions1.5.3, 2.0.1

Products include Apache Superset.

How do I fix CVE-2022-43721?

Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.

Is CVE-2022-43721 being exploited?

There is no known exploitation of CVE-2022-43721 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2022-43721, GHSA-fcg4-pm6h-9xx2, PYSEC-2026-781.

Is CVE-2022-43721 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free