CVE-2022-43755 Rancher: Non-random authentication token

High 7.1 Published Updated

Attackers can reuse cattle-tokens after renewal due to insufficient entropy, allowing continued unauthorized access to Rancher.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-43755?

CVE-2022-43755 is a high-severity vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Insufficient Entropy vulnerability in SUSE Rancher allows attackers that gained knowledge of the cattle-token to continue abusing this even after the token was renewed. This issue affects: SUSE Rancher Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.

Weakness: CWE-331

Which versions are affected by CVE-2022-43755?

4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.

PackageAffectedFixed in
github.com/rancher/rancher GoFrom 2.6.02.6.10
github.com/rancher/rancher GoFrom 2.6.02.6.10
github.com/rancher/rancher GoFrom 2.7.02.7.1
github.com/rancher/rancher GoFrom 2.7.02.7.1

Products include Suse Rancher.

How do I fix CVE-2022-43755?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.6.10 or 2.7.1.

Is CVE-2022-43755 being exploited?

There is no known exploitation of CVE-2022-43755 in the wild and no public exploit code.

Sources

Also known as GHSA-8c69-r38j-rpfj.

Is CVE-2022-43755 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free