CVE-2022-43756 Rancher/Wrangler: Denial of service when processing Git credentials
Remote attackers can cause denial of service in SUSE Rancher by supplying specially crafted Git credentials to the Wrangler library.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-43756?
CVE-2022-43756 is a medium-severity denial of service vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.
Weakness: CWE-74
Which versions are affected by CVE-2022-43756?
9 open source packages ship an affected version, including github.com/rancher/wrangler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/wrangler Go | All versions | 0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1 |
github.com/rancher/wrangler Go | All versions | 0.7.4-security1 |
github.com/rancher/wrangler Go | All versions | 0.7.4-security1 |
github.com/rancher/wrangler Go | From 0.8.0 | 0.8.5-security1 |
github.com/rancher/wrangler Go | From 0.8.0 | 0.8.5-security1 |
github.com/rancher/wrangler Go | From 0.8.6 | 0.8.11 |
3 more packages
github.com/rancher/wrangler Go | From 0.8.6 | 0.8.11 |
github.com/rancher/wrangler Go | From 1.0.0 | 1.0.1 |
github.com/rancher/wrangler Go | From 1.0.0 | 1.0.1 |
Products include Suse Wrangler.
How do I fix CVE-2022-43756?
Upgrade github.com/rancher/wrangler to a fixed version for your release line: 0.7.4-security1, 0.8.5-security1, 0.8.11 or 1.0.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-43756 being exploited?
There is no known exploitation of CVE-2022-43756 in the wild and no public exploit code.
Other vulnerabilities in SUSE Rancher
Sources
Also known as GHSA-8fcj-gf77-47mg, GO-2023-1515.