{"answers":{"affected":"9 open source packages ship an affected version, including github.com/rancher/wrangler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-43756 in the wild and no public exploit code.","fix":"Upgrade github.com/rancher/wrangler to a fixed version for your release line: 0.7.4-security1, 0.8.5-security1, 0.8.11 or 1.0.1.","what":"CVE-2022-43756 is a medium-severity denial of service vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-43756 and fix it if it is affected.\n\nWhat it is: CVE-2022-43756 is a medium-severity denial of service vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-43756 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1\n- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1\n- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1\n- github.com/rancher/wrangler (Go): affected from 0.8.0; fixed in 0.8.5-security1\n- github.com/rancher/wrangler (Go): affected from 0.8.0; fixed in 0.8.5-security1\n- github.com/rancher/wrangler (Go): affected from 0.8.6; fixed in 0.8.11\n- github.com/rancher/wrangler (Go): affected from 0.8.6; fixed in 0.8.11\n- github.com/rancher/wrangler (Go): affected from 1.0.0; fixed in 1.0.1\n- github.com/rancher/wrangler (Go): affected from 1.0.0; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43756/ (Markdown: https://insights.sbomify.com/CVE-2022-43756/index.md)","id":"CVE-2022-43756","markdown":"https://insights.sbomify.com/CVE-2022-43756/index.md","name":"CVE-2022-43756","record":{"aliases":["GHSA-8fcj-gf77-47mg","GO-2023-1515"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go Git library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in SUSE Rancher by supplying specially crafted Git credentials to the Wrangler library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"wrangler","vendor":"suse"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Rancher/Wrangler: Denial of service when processing Git credentials","id":"CVE-2022-43756","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":9,"n_references":1,"next":{"headline":"Rancher: Exposure of sensitive fields","id":"CVE-2022-43757"},"packages":[{"ecosystem":"Go","fixed":["0.7.4-security1","0.8.5-security1","0.8.11","1.0.1"],"introduced":["0","0.8.0","0.8.6","1.0.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GO-2023-1515"},{"ecosystem":"Go","fixed":["0.7.4-security1"],"introduced":["0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-8fcj-gf77-47mg"},{"ecosystem":"Go","fixed":["0.7.4-security1"],"introduced":["0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-8fcj-gf77-47mg"},{"ecosystem":"Go","fixed":["0.8.5-security1"],"introduced":["0.8.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-8fcj-gf77-47mg"},{"ecosystem":"Go","fixed":["0.8.5-security1"],"introduced":["0.8.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-8fcj-gf77-47mg"},{"ecosystem":"Go","fixed":["0.8.11"],"introduced":["0.8.6"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-8fcj-gf77-47mg"},{"ecosystem":"Go","fixed":["0.8.11"],"introduced":["0.8.6"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-8fcj-gf77-47mg"},{"ecosystem":"Go","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-8fcj-gf77-47mg"},{"ecosystem":"Go","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-8fcj-gf77-47mg"}],"prev":{"headline":"Rancher: Non-random authentication token","id":"CVE-2022-43755"},"products":["Rancher"],"published":"2023-02-07","related":[{"cvss_score":7.5,"headline":"[RANCHER] OS command injection in Rancher and Fleet","id":"CVE-2022-31249","kev_date_added":null,"published":"2023-02-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["SUSE"]},"summary":"Remote attackers can cause denial of service in SUSE Rancher by supplying specially crafted Git credentials to the Wrangler library.","url":"https://insights.sbomify.com/CVE-2022-43756/"}