# CVE-2022-43756: Rancher/Wrangler: Denial of service when processing Git credentials

> Remote attackers can cause denial of service in SUSE Rancher by supplying specially crafted Git credentials to the Wrangler library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2023
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-8fcj-gf77-47mg, GO-2023-1515

## What is CVE-2022-43756?

CVE-2022-43756 is a medium-severity denial of service vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-43756?

9 open source packages ship an affected version, including github.com/rancher/wrangler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/wrangler` | Go | All versions | 0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1 |
| `github.com/rancher/wrangler` | Go | All versions | 0.7.4-security1 |
| `github.com/rancher/wrangler` | Go | All versions | 0.7.4-security1 |
| `github.com/rancher/wrangler` | Go | From 0.8.0 | 0.8.5-security1 |
| `github.com/rancher/wrangler` | Go | From 0.8.0 | 0.8.5-security1 |
| `github.com/rancher/wrangler` | Go | From 0.8.6 | 0.8.11 |
| `github.com/rancher/wrangler` | Go | From 0.8.6 | 0.8.11 |
| `github.com/rancher/wrangler` | Go | From 1.0.0 | 1.0.1 |
| `github.com/rancher/wrangler` | Go | From 1.0.0 | 1.0.1 |

Products: Suse Wrangler.

## How do I fix CVE-2022-43756?

Upgrade github.com/rancher/wrangler to a fixed version for your release line: 0.7.4-security1, 0.8.5-security1, 0.8.11 or 1.0.1.

## Is CVE-2022-43756 being exploited?

There is no known exploitation of CVE-2022-43756 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2022-31249](https://insights.sbomify.com/CVE-2022-31249/): [RANCHER] OS command injection in Rancher and Fleet (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43756 and fix it if it is affected.

What it is: CVE-2022-43756 is a medium-severity denial of service vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43756 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1
- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1
- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1
- github.com/rancher/wrangler (Go): affected from 0.8.0; fixed in 0.8.5-security1
- github.com/rancher/wrangler (Go): affected from 0.8.0; fixed in 0.8.5-security1
- github.com/rancher/wrangler (Go): affected from 0.8.6; fixed in 0.8.11
- github.com/rancher/wrangler (Go): affected from 0.8.6; fixed in 0.8.11
- github.com/rancher/wrangler (Go): affected from 1.0.0; fixed in 1.0.1
- github.com/rancher/wrangler (Go): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43756/ (Markdown: https://insights.sbomify.com/CVE-2022-43756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43756
- OSV: https://osv.dev/vulnerability/CVE-2022-43756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43756/
Summaries are generated and may contain mistakes; the official description above is the record.
