CVE-2022-43757 Rancher: Exposure of sensitive fields

Critical 9.9 Published Updated

Users on managed clusters can access cleartext stored credentials, potentially leading to privilege escalation and data exposure.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-43757?

CVE-2022-43757 is a critical vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Cleartext Storage of Sensitive Information vulnerability in SUSE Rancher allows users on managed clusters to gain access to credentials. The impact depends on the credentials exposed This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.

Weakness: CWE-312

Which versions are affected by CVE-2022-43757?

6 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.

PackageAffectedFixed in
github.com/rancher/rancher GoFrom 2.5.02.5.17
github.com/rancher/rancher GoFrom 2.5.02.5.17
github.com/rancher/rancher GoFrom 2.6.02.6.10
github.com/rancher/rancher GoFrom 2.6.02.6.10
github.com/rancher/rancher GoFrom 2.7.02.7.1
github.com/rancher/rancher GoFrom 2.7.02.7.1

Products include Suse Rancher.

How do I fix CVE-2022-43757?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.17, 2.6.10 or 2.7.1.

Is CVE-2022-43757 being exploited?

There is no known exploitation of CVE-2022-43757 in the wild and no public exploit code.

Sources

Also known as GHSA-cq4p-vp5q-4522.

Is CVE-2022-43757 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free