# CVE-2022-43757: Rancher: Exposure of sensitive fields

> Users on managed clusters can access cleartext stored credentials, potentially leading to privilege escalation and data exposure.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2023
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-cq4p-vp5q-4522

## What is CVE-2022-43757?

CVE-2022-43757 is a critical vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Cleartext Storage of Sensitive Information vulnerability in SUSE Rancher allows users on managed clusters to gain access to credentials. The impact depends on the credentials exposed This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2022-43757?

6 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.17 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.17 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.10 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.10 |
| `github.com/rancher/rancher` | Go | From 2.7.0 | 2.7.1 |
| `github.com/rancher/rancher` | Go | From 2.7.0 | 2.7.1 |

Products: Suse Rancher.

## How do I fix CVE-2022-43757?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.17, 2.6.10 or 2.7.1.

## Is CVE-2022-43757 being exploited?

There is no known exploitation of CVE-2022-43757 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)
- [CVE-2019-11202](https://insights.sbomify.com/CVE-2019-11202/): Rancher Recreates Default User With Known Password Despite Deletion (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43757 and fix it if it is affected.

What it is: CVE-2022-43757 is a critical vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43757 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.17
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.17
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.10
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.10
- github.com/rancher/rancher (Go): affected from 2.7.0; fixed in 2.7.1
- github.com/rancher/rancher (Go): affected from 2.7.0; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43757/ (Markdown: https://insights.sbomify.com/CVE-2022-43757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43757
- OSV: https://osv.dev/vulnerability/CVE-2022-43757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43757/
Summaries are generated and may contain mistakes; the official description above is the record.
