CVE-2022-43758 Rancher: Command injection in Git package
Attackers with admin privileges can execute arbitrary code by adding untrusted Helm catalogs or modifying KDM URLs in Rancher.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-43758?
CVE-2022-43758 is a high-severity command injection vulnerability in SUSE Rancher, published on 7 Feb 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in SUSE Rancher allows code execution for user with the ability to add an untrusted Helm catalog or modifying the URL configuration used to download KDM (only admin users by default) This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.
Weakness: CWE-78
Which versions are affected by CVE-2022-43758?
6 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | From 2.5.0 | 2.5.17 |
github.com/rancher/rancher Go | From 2.5.0 | 2.5.17 |
github.com/rancher/rancher Go | From 2.6.0 | 2.6.10 |
github.com/rancher/rancher Go | From 2.6.0 | 2.6.10 |
github.com/rancher/rancher Go | From 2.7.0 | 2.7.1 |
github.com/rancher/rancher Go | From 2.7.0 | 2.7.1 |
Products include Suse Rancher.
How do I fix CVE-2022-43758?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.17, 2.6.10 or 2.7.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-43758 being exploited?
There is no known exploitation of CVE-2022-43758 in the wild and no public exploit code.
Other vulnerabilities in SUSE Rancher
- CVE-2023-22647 Rancher vulnerable to Privilege Escalation via manipulation of Secrets
- CVE-2023-22651 Rancher Webhook is misconfigured during upgrade process
- CVE-2022-43757 Rancher: Exposure of sensitive fields
- CVE-2021-36782 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object
- CVE-2021-36783 Rancher: Failure to properly sanitize credentials in cluster template answers
Sources
Also known as GHSA-34p5-jp77-fcrc.