# CVE-2022-43758: Rancher: Command injection in Git package

> Attackers with admin privileges can execute arbitrary code by adding untrusted Helm catalogs or modifying KDM URLs in Rancher.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Feb 2023
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-34p5-jp77-fcrc

## What is CVE-2022-43758?

CVE-2022-43758 is a high-severity command injection vulnerability in SUSE Rancher, published on 7 Feb 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in SUSE Rancher allows code execution for user with the ability to add an untrusted Helm catalog or modifying the URL configuration used to download KDM (only admin users by default) This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-43758?

6 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.17 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.17 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.10 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.10 |
| `github.com/rancher/rancher` | Go | From 2.7.0 | 2.7.1 |
| `github.com/rancher/rancher` | Go | From 2.7.0 | 2.7.1 |

Products: Suse Rancher.

## How do I fix CVE-2022-43758?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.17, 2.6.10 or 2.7.1.

## Is CVE-2022-43758 being exploited?

There is no known exploitation of CVE-2022-43758 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43758 and fix it if it is affected.

What it is: CVE-2022-43758 is a high-severity command injection vulnerability in SUSE Rancher, published on 7 Feb 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-43758 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.17
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.17
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.10
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.10
- github.com/rancher/rancher (Go): affected from 2.7.0; fixed in 2.7.1
- github.com/rancher/rancher (Go): affected from 2.7.0; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43758/ (Markdown: https://insights.sbomify.com/CVE-2022-43758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43758
- OSV: https://osv.dev/vulnerability/CVE-2022-43758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43758/
Summaries are generated and may contain mistakes; the official description above is the record.
