CVE-2022-43759 Rancher: Privilege escalation via promoted roles

High 7.2 Published Updated

Users with escalate verb access can improperly escalate permissions for promoted resources in any cluster, requiring an upgrade to secure the platform.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-43759?

CVE-2022-43759 is a high-severity vulnerability in SUSE Rancher, published on 7 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A Improper Privilege Management vulnerability in SUSE Rancher, allows users with access to the escalate verb on PRTBs to escalate permissions for any -promoted resource in any cluster. This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10.

Weakness: CWE-269

Which versions are affected by CVE-2022-43759?

4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.

PackageAffectedFixed in
github.com/rancher/rancher GoFrom 2.5.02.5.17
github.com/rancher/rancher GoFrom 2.5.02.5.17
github.com/rancher/rancher GoFrom 2.6.02.6.10
github.com/rancher/rancher GoFrom 2.6.02.6.10

Products include Suse Rancher.

How do I fix CVE-2022-43759?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.17 or 2.6.10.

Is CVE-2022-43759 being exploited?

There is no known exploitation of CVE-2022-43759 in the wild and no public exploit code.

Sources

Also known as GHSA-7m72-mh5r-6j3r.

Is CVE-2022-43759 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free