{"answers":{"affected":"4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-43759 in the wild and no public exploit code.","fix":"Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.17 or 2.6.10.","what":"CVE-2022-43759 is a high-severity vulnerability in SUSE Rancher, published on 7 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-43759 and fix it if it is affected.\n\nWhat it is: CVE-2022-43759 is a high-severity vulnerability in SUSE Rancher, published on 7 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-43759 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.17\n- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.17\n- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.10\n- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-43759/ (Markdown: https://insights.sbomify.com/CVE-2022-43759/index.md)","id":"CVE-2022-43759","markdown":"https://insights.sbomify.com/CVE-2022-43759/index.md","name":"CVE-2022-43759","record":{"aliases":["GHSA-7m72-mh5r-6j3r"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Rancher management platform","requires_auth":"high_privilege","summary":"Users with escalate verb access can improperly escalate permissions for promoted resources in any cluster, requiring an upgrade to secure the platform.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"rancher","vendor":"suse"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"A Improper Privilege Management vulnerability in SUSE Rancher, allows users with access to the escalate verb on PRTBs to escalate permissions for any -promoted resource in any cluster. This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Rancher: Privilege escalation via promoted roles","id":"CVE-2022-43759","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"Rancher UI has multiple Cross-Site Scripting (XSS) issues","id":"CVE-2022-43760"},"packages":[{"ecosystem":"Go","fixed":["2.5.17"],"introduced":["2.5.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-7m72-mh5r-6j3r"},{"ecosystem":"Go","fixed":["2.5.17"],"introduced":["2.5.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-7m72-mh5r-6j3r"},{"ecosystem":"Go","fixed":["2.6.10"],"introduced":["2.6.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-7m72-mh5r-6j3r"},{"ecosystem":"Go","fixed":["2.6.10"],"introduced":["2.6.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-7m72-mh5r-6j3r"}],"prev":{"headline":"Rancher: Command injection in Git package","id":"CVE-2022-43758"},"products":["Rancher"],"published":"2023-02-07","related":[{"cvss_score":9.9,"headline":"Rancher vulnerable to Privilege Escalation via manipulation of Secrets","id":"CVE-2023-22647","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.9,"headline":"Rancher Webhook is misconfigured during upgrade process","id":"CVE-2023-22651","kev_date_added":null,"published":"2023-05-04"},{"cvss_score":9.9,"headline":"Rancher: Exposure of sensitive fields","id":"CVE-2022-43757","kev_date_added":null,"published":"2023-02-07"},{"cvss_score":9.9,"headline":"Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object","id":"CVE-2021-36782","kev_date_added":null,"published":"2022-09-07"},{"cvss_score":9.9,"headline":"Rancher: Failure to properly sanitize credentials in cluster template answers","id":"CVE-2021-36783","kev_date_added":null,"published":"2022-09-07"},{"cvss_score":9.8,"headline":"Rancher Recreates Default User With Known Password Despite Deletion","id":"CVE-2019-11202","kev_date_added":null,"published":"2019-07-30"},{"cvss_score":9.5,"headline":"SAML Authentication Replay in Rancher","id":"CVE-2026-44946","kev_date_added":null,"published":"2026-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["SUSE"]},"summary":"Users with escalate verb access can improperly escalate permissions for promoted resources in any cluster, requiring an upgrade to secure the platform.","url":"https://insights.sbomify.com/CVE-2022-43759/"}