CVE-2022-43760 Rancher UI has multiple Cross-Site Scripting (XSS) issues
Privileged users can inject scripts to steal data or act as administrators in Rancher web interfaces.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-43760?
CVE-2022-43760 is a high-severity cross-site scripting vulnerability in SUSE Rancher, published on 1 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SUSE Rancher allows users in some higher-privileged groups to to inject code that is executed within another user's browser, allowing the attacker to steal sensitive information, manipulate web content, or perform other malicious activities on behalf of the victims. This could result in a user with write access to the affected areas being able to act on behalf of an administrator, once an administrator opens the affected web page.
This issue affects Rancher: from >= 2.6.0 before < 2.6.13, from >= 2.7.0 before < 2.7.4.
Weakness: CWE-79
Which versions are affected by CVE-2022-43760?
4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | From 2.6.0 | 2.6.13 |
github.com/rancher/rancher Go | From 2.6.0 | 2.6.13 |
github.com/rancher/rancher Go | From 2.7.0 | 2.7.4 |
github.com/rancher/rancher Go | From 2.7.0 | 2.7.4 |
Products include Suse Rancher.
How do I fix CVE-2022-43760?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.6.13 or 2.7.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-43760 being exploited?
There is no known exploitation of CVE-2022-43760 in the wild and no public exploit code.
Other vulnerabilities in SUSE Rancher
- CVE-2023-22647 Rancher vulnerable to Privilege Escalation via manipulation of Secrets
- CVE-2023-22651 Rancher Webhook is misconfigured during upgrade process
- CVE-2022-43757 Rancher: Exposure of sensitive fields
- CVE-2021-36782 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object
- CVE-2021-36783 Rancher: Failure to properly sanitize credentials in cluster template answers
Sources
Also known as GHSA-46v3-ggjg-qq3x.