# CVE-2022-43766: Apache IoTDB prior to 0.13.3 allows DoS

> Attackers can cause denial of service in Apache IoTDB by submitting malicious regular expressions, requiring an upgrade or Java version change.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-g6hg-4v3c-6jq7, PYSEC-2022-42972

## What is CVE-2022-43766?

CVE-2022-43766 is a high-severity denial of service vulnerability in Apache IoTDB, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-43766?

9 open source packages ship an affected version, including apache-iotdb, org.apache.iotdb:flink-tsfile-connector and org.apache.iotdb:iotdb-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-iotdb` | PyPI | From 0.12.2 | 0.13.3 |
| `apache-iotdb` | PyPI | From 0.12.2 | 0.13.3 |
| `apache-iotdb` | PyPI | From 0.12.2 | 0.13.3 |
| `org.apache.iotdb:flink-tsfile-connector` | Maven | From 0.12.2 | 0.13.3 |
| `org.apache.iotdb:flink-tsfile-connector` | Maven | From 0.12.2 | 0.13.3 |
| `org.apache.iotdb:iotdb-server` | Maven | From 0.12.2 | 0.13.3 |
| `org.apache.iotdb:iotdb-server` | Maven | From 0.12.2 | 0.13.3 |
| `org.apache.iotdb:tsfile` | Maven | From 0.12.2 | 0.13.3 |
| `org.apache.iotdb:tsfile` | Maven | From 0.12.2 | 0.13.3 |

Products: Apache Iotdb.

## How do I fix CVE-2022-43766?

Upgrade apache-iotdb to 0.13.3 or later.

## Is CVE-2022-43766 being exploited?

There is no known exploitation of CVE-2022-43766 in the wild and no public exploit code.

## Other vulnerabilities in Apache IoTDB

- [CVE-2026-24014](https://insights.sbomify.com/CVE-2026-24014/): Apache IoTDB: Path Traversal in DataNode Internal RPC Trigger JAR Upload Allows Arbitrary File Write (critical 9.8)
- [CVE-2026-24015](https://insights.sbomify.com/CVE-2026-24015/): Apache IoTDB: Insecure Default Configuration Vulnerability (critical 9.8)
- [CVE-2026-24713](https://insights.sbomify.com/CVE-2026-24713/): Apache IoTDB: JEXL Expression Injection Vulnerability (critical 9.8)
- [CVE-2024-24780](https://insights.sbomify.com/CVE-2024-24780/): Apache IoTDB: Remote Code Execution with untrusted URI of User-defined function (critical 9.8)
- [CVE-2023-46226](https://insights.sbomify.com/CVE-2023-46226/): Apache IoTDB: Remote Code Execution (RCE) risk via the UDF (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43766 and fix it if it is affected.

What it is: CVE-2022-43766 is a high-severity denial of service vulnerability in Apache IoTDB, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-43766 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-iotdb (PyPI): affected from 0.12.2; fixed in 0.13.3
- apache-iotdb (PyPI): affected from 0.12.2; fixed in 0.13.3
- apache-iotdb (PyPI): affected from 0.12.2; fixed in 0.13.3
- org.apache.iotdb:flink-tsfile-connector (Maven): affected from 0.12.2; fixed in 0.13.3
- org.apache.iotdb:flink-tsfile-connector (Maven): affected from 0.12.2; fixed in 0.13.3
- org.apache.iotdb:iotdb-server (Maven): affected from 0.12.2; fixed in 0.13.3
- org.apache.iotdb:iotdb-server (Maven): affected from 0.12.2; fixed in 0.13.3
- org.apache.iotdb:tsfile (Maven): affected from 0.12.2; fixed in 0.13.3
- org.apache.iotdb:tsfile (Maven): affected from 0.12.2; fixed in 0.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43766/ (Markdown: https://insights.sbomify.com/CVE-2022-43766/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43766
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43766
- OSV: https://osv.dev/vulnerability/CVE-2022-43766

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43766/
Summaries are generated and may contain mistakes; the official description above is the record.
