# CVE-2022-4385: Intuitive Custom Post Order < 3.1.4 - Subscriber+ Arbitrary Menu Order Update

> A missing authorization check in the Intuitive Custom Post Order plugin allows any logged-in user to arbitrarily update menu order settings.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Feb 2023
- **Updated:** 12 Mar 2025
- **Also known as:** GHSA-q4vc-x2f4-45f6

## What is CVE-2022-4385?

CVE-2022-4385 is a medium-severity missing authorization vulnerability in Unknown Intuitive Custom Post Order, published on 21 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Intuitive Custom Post Order WordPress plugin before 3.1.4 does not check for authorization in the update-menu-order ajax action, allowing any logged in user (with roles as low as Subscriber) to update the menu order

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-4385?

It affects 1 product.


Products: Intuitive Custom Post Order Project Intuitive Custom Post Order.

## How do I fix CVE-2022-4385?

No fix has been published for CVE-2022-4385 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4385 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4385 exists.

## Other vulnerabilities in Unknown Intuitive Custom Post Order

- [CVE-2022-4386](https://insights.sbomify.com/CVE-2022-4386/): Intuitive Custom Post Order < 3.1.4 - Arbitrary Menu Order Update via CSRF (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4385 and fix it if it is affected.

What it is: CVE-2022-4385 is a medium-severity missing authorization vulnerability in Unknown Intuitive Custom Post Order, published on 21 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4385 exists.

Affected product: Unknown Intuitive Custom Post Order. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4385/ (Markdown: https://insights.sbomify.com/CVE-2022-4385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4385
- OSV: https://osv.dev/vulnerability/CVE-2022-4385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4385/
Summaries are generated and may contain mistakes; the official description above is the record.
