{"answers":{"affected":"3 open source packages ship an affected version, including pyrdfa3 and pyRdfa3. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4396 in the wild and no public exploit code.","fix":"Upgrade pyrdfa3 to 3.6.2 or later.","what":"CVE-2022-4396 is a low-severity cross-site scripting vulnerability in RDFlib pyrdfa3, published on 10 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4396 and fix it if it is affected.\n\nWhat it is: CVE-2022-4396 is a low-severity cross-site scripting vulnerability in RDFlib pyrdfa3, published on 10 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4396 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyrdfa3 (PyPI): affected all versions; fixed in 3.6.2\n- pyrdfa3 (PyPI): affected all versions; fixed in 3.6.2\n- pyRdfa3 (PyPI): affected all versions; fixed in 3.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4396/ (Markdown: https://insights.sbomify.com/CVE-2022-4396/index.md)","id":"CVE-2022-4396","markdown":"https://insights.sbomify.com/CVE-2022-4396/index.md","name":"CVE-2022-4396","record":{"aliases":["DEBIAN-CVE-2022-4396","GHSA-894q-wpg5-mf2h","PYSEC-2026-910","UBUNTU-CVE-2022-4396"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python RDF library","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the RDFlib pyrdfa3 library's option handling.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"pyrdfa3","vendor":"pyrdfa3_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability was found in RDFlib pyrdfa3 and classified as problematic. This issue affects the function _get_option of the file pyRdfa/__init__.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. The name of the patch is ffd1d62dd50d5f4190013b39cedcdfbd81f3ce3e. It is recommended to apply a patch to fix this issue. The identifier VDB-215249 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RDFlib pyrdfa3 __init__.py _get_option cross site scripting","id":"CVE-2022-4396","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"morontt zend-blog-number-2 Comment Comment.php cross-site request forgery","id":"CVE-2022-4397"},"packages":[{"ecosystem":"PyPI","fixed":["3.6.2"],"introduced":["0"],"last_affected":[],"package":"pyRdfa3","purl":null,"source":"GHSA-894q-wpg5-mf2h"},{"ecosystem":"PyPI","fixed":["3.6.2"],"introduced":["0"],"last_affected":[],"package":"pyrdfa3","purl":"pkg:pypi/pyrdfa3","source":"GHSA-894q-wpg5-mf2h"},{"ecosystem":"PyPI","fixed":["3.6.2"],"introduced":["0"],"last_affected":[],"package":"pyrdfa3","purl":"pkg:pypi/pyrdfa3","source":"PYSEC-2026-910"}],"prev":{"headline":"Membership For WooCommerce \u003c 2.1.7 - Unauthenticated Arbitrary File Upload","id":"CVE-2022-4395"},"products":["pyrdfa3"],"published":"2022-12-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["RDFlib"]},"summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the RDFlib pyrdfa3 library's option handling.","url":"https://insights.sbomify.com/CVE-2022-4396/"}