# CVE-2022-4396: RDFlib pyrdfa3 __init__.py _get_option cross site scripting

> Remote attackers can execute arbitrary scripts via cross-site scripting in the RDFlib pyrdfa3 library's option handling.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-4396, GHSA-894q-wpg5-mf2h, PYSEC-2026-910, UBUNTU-CVE-2022-4396

## What is CVE-2022-4396?

CVE-2022-4396 is a low-severity cross-site scripting vulnerability in RDFlib pyrdfa3, published on 10 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in RDFlib pyrdfa3 and classified as problematic. This issue affects the function _get_option of the file pyRdfa/__init__.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. The name of the patch is ffd1d62dd50d5f4190013b39cedcdfbd81f3ce3e. It is recommended to apply a patch to fix this issue. The identifier VDB-215249 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-4396?

3 open source packages ship an affected version, including pyrdfa3 and pyRdfa3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyrdfa3` | PyPI | All versions | 3.6.2 |
| `pyrdfa3` | PyPI | All versions | 3.6.2 |
| `pyRdfa3` | PyPI | All versions | 3.6.2 |

Products: Pyrdfa3 Project Pyrdfa3.

## How do I fix CVE-2022-4396?

Upgrade pyrdfa3 to 3.6.2 or later.

## Is CVE-2022-4396 being exploited?

There is no known exploitation of CVE-2022-4396 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4396 and fix it if it is affected.

What it is: CVE-2022-4396 is a low-severity cross-site scripting vulnerability in RDFlib pyrdfa3, published on 10 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4396 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyrdfa3 (PyPI): affected all versions; fixed in 3.6.2
- pyrdfa3 (PyPI): affected all versions; fixed in 3.6.2
- pyRdfa3 (PyPI): affected all versions; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4396/ (Markdown: https://insights.sbomify.com/CVE-2022-4396/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4396
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4396
- OSV: https://osv.dev/vulnerability/CVE-2022-4396

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4396/
Summaries are generated and may contain mistakes; the official description above is the record.
